Bugs related with card reader

Post Reply
Chelsona
Posts: 13
Joined: Oct 31st, 2008, 9:05 am
Location: Seoul, Rep. of Korea

Bugs related with card reader

Post by Chelsona » Nov 12th, 2008, 4:04 am

Version 4.0 Beta 7 in Windows Vista 64-bit edition.
Some bugs I found while working with my builtin card reader.

1) Resizable message dialog
"Trying to return USB device(s) back" message dialog is resizable now. I think it is not supposed to resizable...

2) Return device failure
I failed to return my USB interface card reader device by the feature. There is any responses on the restoring dialog; it just keep trying to restoring the device and nothing have changed. No error message is appeared.
The card reader is connected through mainboard USB interface; maybe it is the reason but I'm not sure.

3) Folder mount error
(Maybe this error occurs not only with card reader)
After mounting a memory card on a folder, I ejected it, and I created a file in the mount folder. Next time I connected the memory card, the file in the folder is permanantly disappeared, and device property of USB Safely Remove is broken. Drive letter setting and mount folder setting is somehow messed up and cannot be repaired by program. I had to delete the device setting directly in REGEDIT.
If designated folder has some files, I think it is better to alert that "Designated mount folder is not blank!" and give user two choices: do not mount on the folder, or delete everything in the folder and mount on it.
User avatar
Igor
Developer
Posts: 563
Joined: Nov 1st, 2007, 12:44 pm
Location: Saint Petersburg
Contact:

Re: Bugs related with card reader

Post by Igor » Nov 12th, 2008, 10:48 am

Chelsona,
Thanks for the bug report!
Chelsona wrote: 1) Resizable message dialog
"Trying to return USB device(s) back" message dialog is resizable now. I think it is not supposed to resizable...
You're right. We will fix it.
Chelsona wrote: 2) Return device failure
I failed to return my USB interface card reader device by the feature. There is any responses on the restoring dialog; it just keep trying to restoring the device and nothing have changed. No error message is appeared.
This feature is not available in Vista 64. We are currently work on this issue and I hope we'll release version that fixes it in a week.
Chelsona wrote: 3) Folder mount error
(Maybe this error occurs not only with card reader)
After mounting a memory card on a folder, I ejected it, and I created a file in the mount folder. Next time I connected the memory card, the file in the folder is permanantly disappeared, and device property of USB Safely Remove is broken. Drive letter setting and mount folder setting is somehow messed up and cannot be repaired by program. I had to delete the device setting directly in REGEDIT.
If designated folder has some files, I think it is better to alert that "Designated mount folder is not blank!" and give user two choices: do not mount on the folder, or delete everything in the folder and mount on it.
Thanks for the report. We will work on it.
Post Reply