SafelyRemove.com Forum
http://safelyremove.com/forum/

2-byte character is broken when be deleted
http://safelyremove.com/forum/viewtopic.php?f=2&t=150
Page 1 of 1

Author:  Chelsona [ Mon Dec 01, 2008 1:29 am ]
Post subject:  2-byte character is broken when be deleted

It is not a functional bug.
Beta 8 (build 750) on MS Windows Vista x64 (Korean)

In the "device property" menu, 2-byte characters such as Korean broke up when be deleted by 'backspace' key. 'Delete' key works fine.
I tried to do the same thing for some Japanese characters, and the result was same.

Also, when I input device name in Korean, autofill function for the device name not correctly works.

Maybe some of the character based function calls should be replaced with functions with wide character support.

Author:  Igor [ Mon Dec 01, 2008 4:17 pm ]
Post subject:  Re: 2-byte character is broken when be deleted

Chelsona wrote:
It is not a functional bug.
Beta 8 (build 750) on MS Windows Vista x64 (Korean)

In the "device property" menu, 2-byte characters such as Korean broke up when be deleted by 'backspace' key. 'Delete' key works fine.
I tried to do the same thing for some Japanese characters, and the result was same.

Also, when I input device name in Korean, autofill function for the device name not correctly works.

Maybe some of the character based function calls should be replaced with functions with wide character support.

We will provide a fully unicode interface in the next versions... And now the version is ANSI encoded so there might be such kind of bugs.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/