"USB Safely Remove 4.0" 2 bugs found when using in Windows 7 beta!

Post Reply
gate1975mlm
Posts: 3
Joined: Feb 17th, 2009, 5:29 pm

"USB Safely Remove 4.0" 2 bugs found when using in Windows 7 beta!

Post by gate1975mlm » Feb 17th, 2009, 5:54 pm

I may have found 2 bugs in USB Safely Remove 4.0.9.760 when running on Windows 7 Beta.

First bug

Under "Look and Feel" Replace native "Safely Remove Hardware Icon" does not seem to be working. Because both USB Safely Remove and Safely Remove Hardware Icon both keep showing at the same time.

Second bug

When I click Apple iPod USB Device to safely remove it I get a box that pops up with a message that reads " The device "Apple iPod USB Device (M)" is going to be disabled, because its driver dosen't support the authentic "Safe removal" feature.

This is with a 3rd Gen iPod Nano.

Also take a look at the pic to see what I mean.

Image
User avatar
Igor
Developer
Posts: 562
Joined: Nov 1st, 2007, 12:44 pm
Location: Saint Petersburg
Contact:

Re: "USB Safely Remove 4.0" 2 bugs found when using in Windows 7 beta!

Post by Igor » Feb 18th, 2009, 3:29 am

gate1975mlm wrote:I may have found 2 bugs in USB Safely Remove 4.0.9.760 when running on Windows 7 Beta.

First bug

Under "Look and Feel" Replace native "Safely Remove Hardware Icon" does not seem to be working. Because both USB Safely Remove and Safely Remove Hardware Icon both keep showing at the same time.

Second bug

When I click Apple iPod USB Device to safely remove it I get a box that pops up with a message that reads " The device "Apple iPod USB Device (M)" is going to be disabled, because its driver dosen't support the authentic "Safe removal" feature.

This is with a 3rd Gen iPod Nano.
Thank you very much for the bug-report! We will test our next versions under Windows 7 and try to fix all the bugs you've mentioned. Also could you send us device technial information, please? You may find it on the "Technical Information" tab of device properties dialog.
gate1975mlm
Posts: 3
Joined: Feb 17th, 2009, 5:29 pm

Post by gate1975mlm » Feb 18th, 2009, 3:33 am

Internal_UserDeviceNameWithDriveLetters: Apple iPod USB Device (M:)
Sys_DevicePnPName: USBSTOR\DISK&VEN_APPLE&PROD_IPOD&REV_1.62\000A27001BAAB169&0
Sys_FriendlyName: Apple iPod USB Device
Sys_DeviceDescription:
Sys_LocationInformation:
Sys_DeviceInstance: 14888
Sys_HardwareID:
Sys_DriveLetter: M:
Sys_VolumeLabel: MICHAEL'S I
Sys_ulProblemNumber: 0
Sys_BusType: BusTypeUsb
Internal_DontShowThisDevice: False
Internal_IgnoreStopAllCommand: False
Internal_ImageName: iPod
Internal_Hotkey:
Internal_UserDeviceName: Apple iPod USB Device
Internal_IsCardReader: False
Internal_IsProbablyFixedDrive: True
Internal_DeviceIsDisabled: False
Internal_DeviceIsSafelyRemoved: False
Internal_DeviceWasDisabledByProgram: False
Sys_VolumesList:
#UniqueVolume number 1
VolumeName: \\?\Volume{4343a66c-fb7f-11dd-8039-001b2124b55e}\
VolumeMountPoints: M:
VolumeInformation: VolumeLabel = MICHAEL'S I
VolumeSerialNo = $31415926
MaxComponentLength = 255
FileSystemFlags = $0006
FileSystemName = FAT32
debugGetVolumeInformationExecTime(Ticks) = 0
FriendlyName: Apple iPod USB Device
MediaType: 11
###
Internal_PhysicalDeviceLink:
------- Physical Device, level 1 ------
DeviceInst=14888
PnPName=USBSTOR\DISK&VEN_APPLE&PROD_IPOD&REV_1.62\000A27001BAAB169&0
FriendlyName=Apple iPod USB Device
DEVICEDESC=
LOCATION_INFORMATION=
HARDWAREID=
SPDRP_CLASSGUID={4d36e967-e325-11ce-bfc1-08002be10318}
ParentDeviceInst=24656
ParentDevicePnPName=USB\VID_05AC&PID_1262&MI_00\000A27001BAAB169&AAPL0
ulStatus=$0180200A
ulProblemNumber=0
Capabilities=$00000010
DN_REMOVABLE_Flag=False
DN_DISABLEABLE_Flag=True
DN_WILL_BE_REMOVED_Flag=False
DN_HAS_PROBLEM_Flag=False
DN_LIAR_Flag=False
CM_DEVCAP_SURPRISEREMOVALOK_Flag=False
CM_DEVCAP_DOCKDEVICE_Flag=False
CM_DEVCAP_REMOVABLE_Flag=False
CM_PROB_DEVICE_NOT_THERE_Flag=False
SPDRP_PHYSICAL_DEVICE_OBJECT_NAME=\Device\000000c3
SPDRP_UI_NUMBER=0
BusType=BusTypeUsb
DeviceType=FILE_DEVICE_DISK
DeviceNumber=8
DevicePath#0=\\?\usbstor#disk&ven_apple&prod_ipod&rev_1.62#000a27001baab169&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}
MountPoints=M:


Hope that helps :)
User avatar
Igor
Developer
Posts: 562
Joined: Nov 1st, 2007, 12:44 pm
Location: Saint Petersburg
Contact:

Post by Igor » Feb 18th, 2009, 3:55 am

gate1975mlm wrote: Hope that helps :)
Thank you! Could you also send us a bug-report from the program (Menu -> Help -> Report a bug), and in the opened dialog type a short description of the problem and gave a link to this post.
gate1975mlm
Posts: 3
Joined: Feb 17th, 2009, 5:29 pm

Post by gate1975mlm » Feb 18th, 2009, 4:02 am

Igor wrote:
gate1975mlm wrote: Hope that helps :)
Thank you! Could you also send us a bug-report from the program (Menu -> Help -> Report a bug), and in the opened dialog type a short description of the problem and gave a link to this post.
Bug report sent :)
Post Reply