prob stopping new usb hard drive sometimes (Maxtor Basic 500GB)

Post Reply
Trev333
Posts: 1
Joined: May 1st, 2009, 7:42 pm

prob stopping new usb hard drive sometimes (Maxtor Basic 500GB)

Post by Trev333 » May 1st, 2009, 7:54 pm

hi ive been having trouble using safe remove thing in vista x64 with new usb hard drive. so i googled it and came up with here.

ive been using USB Safely Remove few days now sometimes it work and some times had to force stop a process.

but now i come across that some thing that could not b stop and im wondering if any1 knows anything bout them

http://img9.imageshack.us/img9/8753/usbsafelyremove.jpg

btw ive updated to 4.1 and still same

if need any more info please ask im happy to help

hope this help and some 1 knows what this is thanks in advance trev
User avatar
Igor
Developer
Posts: 563
Joined: Nov 1st, 2007, 12:44 pm
Location: Saint Petersburg
Contact:

Re: prob stopping new usb hard drive sometimes (Maxtor Basic 500GB)

Post by Igor » May 21st, 2009, 11:39 am

Trev333 wrote:hi ive been having trouble using safe remove thing in vista x64 with new usb hard drive. so i googled it and came up with here.

ive been using USB Safely Remove few days now sometimes it work and some times had to force stop a process.

but now i come across that some thing that could not b stop and im wondering if any1 knows anything bout them

http://img9.imageshack.us/img9/8753/usbsafelyremove.jpg

btw ive updated to 4.1 and still same

if need any more info please ask im happy to help

hope this help and some 1 knows what this is thanks in advance trev
Hello,
I'm sorry for so late response.

Yes, sometimes Vista's kernle locks the external drive and normal processes cannot unlock it. In the next version (4.2) we will concentrate on improvement of the stopping mechanism and will try to implement a way of forced independent from Windows stopping of drives.
Post Reply