SafelyRemove.com Forum
http://safelyremove.com/forum/

Vista: Problems Stopping SATA Hard Drive in USB Enclosure
http://safelyremove.com/forum/viewtopic.php?f=2&t=207
Page 1 of 1

Author:  DavidT [ Wed May 13, 2009 3:41 pm ]
Post subject:  Vista: Problems Stopping SATA Hard Drive in USB Enclosure

Like others in this forum I'm having problems persuading Vista to let go of SATA hard drives using Vista's Safely Remove function. Unfortunately USB SafelyRemove can't do it either. I'm offering the following observations in case they help you to find a solution, in which case I'll be only too pleased to purchase :-).

For backup I use Casper to clone my main SATA hard drive to an external SATA hard drive in a USB enclosure. After the cloning finishes I can't get Vista to release the drive. It doesn’t seem to happen (yet) with another SATA drive that contains drive images made with Acronis True Image, so I'm wondering if it's because the external drive contains the cloned operating system as opposed to just an image file.

The problem shows up for me in these various ways:

1. USB SafelyRemove shows a list like this screenshot http://img9.imageshack.us/img9/8753/usbsafelyremove.jpg (posted by Trevor at http://safelyremove.com/forum/viewtopic.php?t=202).
2. Sometimes I get a warning message in red saying 'Could not find any processes locking USB device!' (as illustrated by LNH at http://safelyremove.com/forum/viewtopic.php?t=83).
3. Sometimes when I run Unlocker it shows three svchost.exe instances, and sometimes but not always, the Unlock All button on Unlocker will close them. (As proven by running Unlocker again, in which case it comes up blank).
4. If Unlocker *does* clear the processes and I then run USB Safely Remove or Vista's Safely Remove, the external drive activates for a few seconds and the processes come back again.
5. Sometimes I get the red warning message from USB Safely Remove but Unlocker does not show any locking handles. However I can still find them and clear them using Process Explorer from SysInternals. I search for 'f:' (f: is the external drive) in Find /Find Handle or DLL. This produces the Handles in the screenshot here [oops - can't see how to include the screenshot], which are similar to those in Trevor's screenshot (see 1) and those posted by Mysteryman at http://safelyremove.com/forum/viewtopic.php?t=129. I can then close these from their right-click menu.
6. Again, if I clear the handles using Process Explorer and run USB Safely Remove or Vista's Safely Remove, the external drive activates for about 20s and the processes come back again.
7. If I close the Handles with Unlocker or Process Explorer, remove the drive, replace it, and then immediately try to remove it, I have to go through the same unlocking procedure again.

Suggestion: What about making USB SafelyRemove duplicate the manual method I described above using Process Explorer (see 5), but without doing the things that re-activate the disk and make the handles come back again? Do you think this would be safe for data on the disk?

Notes: I've tried ver 4.0.9.779 and 4.1.2.777 beta with Vista Business SP1 on a Toshiba R500.

Author:  Igor [ Thu May 21, 2009 8:06 am ]
Post subject:  Re: Vista: Problems Stopping SATA Hard Drive in USB Enclosure

Hello David,
Thank you very much for so detailed report about the problem. We will devote our next version 4.1 to safe removal mechanism improvements. We will try to find a way on how to do forced safe removal when there are no locking processes.

P.S.
And I apologize for the delay with the response.

Author:  palip [ Tue Aug 04, 2009 3:57 pm ]
Post subject:  sata hard drive

Anyone tried using an external sata hard drive?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/