NVME SSD on USB is not ejected correctly

Post Reply
Techland
Posts: 42
Joined: Aug 23rd, 2010, 2:07 am

NVME SSD on USB is not ejected correctly

Post by Techland »

Hi everyone,

I see a bit strange behaviour that might be a bug in USBSR. I have a normal Windows 10 machine and connect a Samsung NVME SSD that is built into a small JMicron Tech controller equipped adapter via USB 3. Quite quick (and portable) when doing backups!

Now this external drive does not have the write cache enabled (Windows default), so I can easily unplug it any time, the drive letter and the disk will vanish from the system.

But as a long-time USBSR user I am used to - and would prefer to - eject the disk via USBSR. That works with anything else, inlcuding SATA SSDs with adapters to USB 3 etc etc.

The NVME with the JMicron is the only one in my collection where this happens: after eject via USBSR the dialog 'can now be removed' comes up. I unplug the disk, and the second dialog which shows the actual removal of the SSD does not go away. The disk IS eject, but somehow USBSR or Windows get lost in that process. USBSR also continues to show the SSD with a red cross. The drive letter is not removed in Total Commander, but shown with a question mark beside it.

The really bad thing about this is that the 'hanging' disk stays like this forever within the system, and upon shutdown (or reboot) it turns out that the computer will never finish that. I have to do a hard reset on the blue shutdown screen.

Have a nice Sunday evening!
User avatar
Igor
Developer
Posts: 589
Joined: Nov 1st, 2007, 12:44 pm
Location: Saint Petersburg
Contact:

Re: NVME SSD on USB is not ejected correctly

Post by Igor »

Hi Techland,
Can you try to play with this option?
device_stop_method.png
device_stop_method.png (29.13 KiB) Viewed 9307 times

Return the drive into an active state, change the mentioned option to a different value, and then try to stop the drive and see what will happen with it.
Techland
Posts: 42
Joined: Aug 23rd, 2010, 2:07 am

Re: NVME SSD on USB is not ejected correctly

Post by Techland »

Hi Igor,
sorry for the late reply. That option doesn't change anything. But maybe my description above was not accurate enough. I just had this:

- click on the symbol of the JMicron SSD in the USR List. A small window occures saying 'trying to remove the device'. A few seconds later USR activates from the taskbar and shows a message that the disk can now be removed. The small window is still there! So I remove the disk. USR shows a red cross on its taskbar symbol. The small window is still there - trying to close it with its x symbol gives the standard error message 'USR does not react blabla sent to MS bla'.

At this point Windows is already unstable and will hang on shutdown, so the computer needs to be hard switched off. This can corrupt Windows, and that's why I don't want to do this again.
Techland
Posts: 42
Joined: Aug 23rd, 2010, 2:07 am

Re: NVME SSD on USB is not ejected correctly

Post by Techland »

As a follow-up: I now use very nice Crucial X8 to backup my computers. These run very quick without the need to use write cache. Therefore I can easily just disconnect them after the backup without using USR, avoiding the hang issue completely.

I stil hope this can be examined and fixed one day.
Post Reply