Page 1 of 1

instal failed - MoveFile failed; code32 when extracting USBS

Posted: Aug 8th, 2011, 5:26 pm
by bkp13
  • installing on XP sp3 external drive G
    also have "my documents" routed of C to G
    no programs started except what's in the system tray which is not normally a problem.

Where does USBSafelyRemove.chm what to be installed?
error text: G:\ProgramFiles\GOTDF\USB Safely Remove\USBSafelyRemove.chm
An error occurred while trying to rename a file in the destination directory:
MoveFile failed; code 32
the process cannot access the file because it is being used by another process.
Click retry to try again, Ignore to skip this file (not recommended) or Abort to cancel installation.
Retry - same error
Ignore - progressed to antoher Move File failed - this time on the file USBSafelyRemoveRu.chm
Retry - same error
Ignore - progressed to install complete. Seems to work but no f1 help


Re: instal failed - MoveFile failed; code32 when extracting

Posted: Aug 12th, 2011, 2:00 pm
by Igor
Hi Brenda,
I apologize for the delay with the response.

I do not recommend you to install USB Safely Remove into an external drive, since USB Safely Remove's not a portable app.

In your case it's better to uninstall the program, restart the computer and try to install it again into the Program Files folder of your system drive, or into another folder but of a fixed drive.

Re: instal failed - MoveFile failed; code32 when extracting

Posted: Aug 19th, 2011, 5:42 pm
by bkp13
Thanks for the info but I don't think it should apply to my configuration. My G drive is a 2T eSATA Pro Drive - installed and configured as a normal drive, not removable media. Sorry for the confusion. I install all my non system programs on it.

The fact is that USB Safely Remove functions fine installed on the G drive. I just have no help files because of the error. I suspect the install is hard coded to put the help file on C:\..... or it's not included in the install package.

If this program has to be installed on the C: drive then it's not for me as well as many others who don't put anything except system files on C.


Re: instal failed - MoveFile failed; code32 when extracting

Posted: Aug 23rd, 2011, 2:20 pm
by Igor
The program can be installed onto any drive and any folder where you have enough rights. I've just tried to install on non system drive and everything works flawlessly so I actually I cannot understand what may cause your problems with installation of USBSR. Perhaps that's a problem of your system configuration which somehow reject installing chm files.

You can try to do the following steps:
1. Uninstall USB Safely Remove
2. Restart the computer
3. Delete the folder where you installed USB Safely Remove if it exists ( G:\ProgramFiles\GOTDF\USB Safely Remove\)
4. Download the latest version from our web-site: USB Safely Remove 4.7
5. Try to install it to this folder again

Re: instal failed - MoveFile failed; code32 when extracting

Posted: Aug 23rd, 2011, 8:28 pm
by bkp13
Thanks - I'm the only user and admin. I tried the things you suggest before coming to the forum for help. And I have successfully install many many other programs in my current configuration without failing like this. I suspect I do have a unique setup that the install program doesn't recognize and handle. Please let me know, in your test install, where does the help chm file reside (path)?

I don't think this is worth more effort form either of us. Especially since the app does function properly - I just have no help file. So is there any chance I could get the help file separately?